Security Advisories

The Onapsis Research Labs delivers regular SAP® and Oracle® vulnerability research to our ecosystem of customers, partners and the information security industry.

Onapsis security advisories enable customers to better understand the security and business implications of discovered SAP and Oracle security issues. This enables organizations to prioritize patches, updates and their remediation strategies to ensure continuity of the business. Onapsis security advisories, together with vendor patches and security notes, are available for download to provide vendors and end-users with the necessary information to mitigate advanced threats to mission-critical applications running on SAP and Oracle.

Critical 03/19/2021 SAP JAVA

SAP Java OS Remote Code Execution

Impact On Business

A malicious authenticated attacker could abuse some particular services exposed by the SAP JAVA Netweaver allowing them to execute commands in the underlying operating system.

 

Affected Components Description

SAP NetWeaver JAVA is a foundational layer which is used by several SAP products, such as: 

  • SAP Enterprise portal 
  • SAP Solution Manager
  • SAP PI/PO
  • SAP Landscape Manager
  • among others.

Due to the vulnerable components residing in this "foundational layer", all products running on top of SAP JAVA NetWeaver will be affected by this vulnerability.  

Affected components:

  • SAP Netweaver JAVA version 7.30 - 7.50

(Check SAP Note #2979062 for detailed information on affected releases)

 

Vulnerability Details

A particular part (UDDI SERVER) of the SAP JAVA Netweaver layer, exposes a functionality which allows authenticated attackers to upload resources. In particular, at least the NWA_SUPERADMIN privileges are needed to be able to use the upload process. Due to lack of controls, these files are not checked and therefore any type of files could be uploaded, resulting in the possibility of executing commands in the underlying OS.

 

Solution

SAP has released SAP Note #2979062 which provides patched versions of the affected components.

The patches can be downloaded from: https://service.sap.com/sap/support/notes/2979062.

Onapsis strongly recommends SAP customers to download the related security fixes and apply them to the affected components in order to reduce business risks.

 

Report Timeline

  • 05/10/2020:  Onapsis sends details to SAP
  • 05/10/2020:  SAP provides internal ID’s.
  • 12/10/2020:  SAP confirms vulnerability and assigns CVSSv3 score of 9.1 (NLHN|C|HHH)
  • 10/11/2020: SAP releases patch.

 

References

ADVISORY INFORMATION

  • Public Release Date: 03/19/2021
  • Security Advisory ID: ONAPSIS-2021-0004
  • Vulnerability Submission ID: 847
  • Researcher(s): Pablo Artuso

 

VULNERABILITY INFORMATION

  • Vendor: SAP
  • Vulnerability Class: |LS|CWE-434|RS|  Unrestricted Upload of File with Dangerous Type
  • CVSS v3 score: 9.1 (AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H)
  • Severity:  Critical
  • CVE:  CVE-2020-26820
  • Vendor patch Information: SAP Security Note #2979062

 

ABOUT OUR RESEARCH LABS

Onapsis Research Labs provides the industry analysis of key security issues that impact mission-critical systems and applications.

Delivering frequent and timely security and compliance advisories with associated risk levels, Onapsis Research Labs combine in-depth knowledge and experience to deliver technical and business-context with sound security judgment to the broader information security community.

Find all reported vulnerabilities at https://github.com/Onapsis/vulnerability_advisories

 

LICENSE

This advisory is licensed under a Creative Commons 4.0 BY-ND International License

Secure your 
business-critical SAP,
Oracle, Salesforce
and SaaS apps

Get a firsthand look at the visibility, reporting and automation capabilities provided by The Onapsis Platform by scheduling a personalized demo with our application security experts.

Request a demo