Security Advisories

The Onapsis Research Labs delivers regular SAP® and Oracle® vulnerability research to our ecosystem of customers, partners and the information security industry.

Onapsis security advisories enable customers to better understand the security and business implications of discovered SAP and Oracle security issues. This enables organizations to prioritize patches, updates and their remediation strategies to ensure continuity of the business. Onapsis security advisories, together with vendor patches and security notes, are available for download to provide vendors and end-users with the necessary information to mitigate advanced threats to mission-critical applications running on SAP and Oracle.

Critical 06/14/2021 SAP Netweaver JAVA

Missing Authentication Check In SAP NetWeaver

Impact On Business

A malicious unauthenticated user could abuse the lack of authentication check on SAP Java P2P cluster communication, in order  to connect to the respective TCP ports and perform different privileged actions, such as:

  • Installing new trusted SSO providers
  • Changing database connection parameters
  • Gaining access to configuration information
  • Modify network configurations and potentially affect internal networks


Affected Components Description

SAP Netweaver JAVA version 7.10 - 7.50

(Check SAP Note #2974774 for detailed information on affected releases)


Vulnerability Details

The Cluster Manager introduced in SAP AS Java since 7.10, listens by default on all interfaces. The TCP port where the CM listens is defined, as several SAP products, by a port pattern. In this case the following structure defined the port: 50000+100*<instance_number>+20+<node>*5
Where <instance_numbers> refers to the JAVA instance number of the system and <node> the node number within the custer.

Due to several missing authentication checks, a threat actor that is able to reach the Cluster Manager TCP port, could execute highly privileged actions allowing them to gain SAP system administrator access or perform denial of service without authentication among others.

 

Solution

SAP has released SAP Note #2974774 which provides patched versions of the affected components.

The patches can be downloaded from https://launchpad.support.sap.com/#/notes/2974774.

Onapsis strongly recommends SAP customers to download the related security fixes and apply them to the affected components in order to reduce business risks.


Report Timeline

  • 08/26/2020: Onapsis provides vulnerability details to SAP
  • 08/26/2020: SAP provides internal tracking number
  • 10/12/2020: SAP provides update: Vulnerability confirmed – fix in progress
  • 12/08/2020: SAP releases SAP Note fixing the issue.

 


REFERENCES

Advisory Information

  • Public Release Date: 06/14/2021
  • Security Advisory ID: ONAPSIS-2021-0013
  • Vulnerability Submission ID: 838, 839, 840, 844
  • Researcher(s): Ignacio Favro


Vulnerability Information

  • Vendor: SAP
  • Vulnerability Class: |LS|CWE-306|RS| Missing Authentication for Critical Function
  • CVSS v3 score: 10.0 (AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H)
  • Severity: Critical
  • CVE:  CVE-2020-26829
  • Vendor patch Information: SAP Security Note 2974774

ABOUT OUR RESEARCH LABS

Onapsis Research Labs provides the industry analysis of key security issues that impact mission-critical systems and applications.

Delivering frequent and timely security and compliance advisories with associated risk levels, Onapsis Research Labs combine in-depth knowledge

and experience to deliver technical and business-context with sound security judgment to the broader information security community.

Find all reported vulnerabilities at https://github.com/Onapsis/vulnerability_advisories


This advisory is licensed under a Creative Commons 4.0 BY-ND International License